Bug #75982

Can not select Checkbox in Tree Wizard

Added by Philipp Wrann about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2016-04-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Just updated from 6.2.15 to 6.2.22 and recognized i can not select any item from a rendered checkbox tree anymore.

When going back to 6.2.21 it works, so i suspect this change:
https://review.typo3.org/47900

This happens if a record has a checkbox/tree field and no element is selected, so i unselect a static "please choose" option and want to activate one checkbox from below (see screenshot)

The click has no effect.

Browser = Firefox/Ubuntu
Typo3 Version = 6.2

TCA for that field:

'sub_type' => array(
    'exclude' => 0,
    'label' => $ll.'property.subType',
    'config' => array(
        'type' => 'select',
        'items' => array(
            array(
                $ll.'property.subType.default',
                '0'
            )
        ),
        'default' => 0,
        'foreign_table' => 'tx_ext_domain_model_subtype',
        'foreign_table_where' => 'AND tx_ext_domain_model_subtype.sys_language_uid IN (-1, 0) AND tx_ext_domain_model_subtype.type = ###REC_FIELD_type### ORDER BY tx_ext_domain_model_subtype.name ASC',
        'size' => 5,
        'autoSizeMax' => 10,
        'maxitems' => 1,
        'minitems' => 0,
        'renderMode' => 'tree',
        'treeConfig' => array(
            'parentField' => 'parent'
        )
    ),
    'l10n_mode' => 'exclude',
    'l10n_display' => 'defaultAsReadonly'
),


Files

tree-error.png (27.3 KB) tree-error.png Philipp Wrann, 2016-04-29 13:50

Related issues

Is duplicate of TYPO3 Core - Bug #75947: Creation of subcategories impossible after upgrading to 6.2.22Closed2016-04-27

Actions

Also available in: Atom PDF