Bug #75947

Creation of subcategories impossible after upgrading to 6.2.22

Added by Klaus Moser over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2016-04-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

After upgrading to Typo3 6.2.22 it is impossible to create subcateogires to existing (sys_)categories.

Selecting a parent node in the tree select causes a yellow exclamation mark claiming something to be wrong and saving is not possible anymore.

After downgrading to 6.2.21 the error disappeared.


Related issues

Related to TYPO3 Core - Bug #75519: Flexform select rendermode tree doesn't respect collapsed nodesClosedFrans Saris2016-04-11

Actions
Related to TYPO3 Core - Bug #76374: Select trees not rendered on inline recordsClosed2016-05-30

Actions
Has duplicate TYPO3 Core - Bug #75982: Can not select Checkbox in Tree WizardClosed2016-04-29

Actions
Has duplicate TYPO3 Core - Bug #76165: Checkboxes in sys_category for parent are not working anymoreClosed2016-05-12

Actions
Has duplicate TYPO3 Core - Bug #76184: Parent Category could not be setClosed2016-05-13

Actions
#1

Updated by Klaus Moser over 5 years ago

After unchecking a parent node no checkbox is checkable anymore. In 6.2.22 the select treeview is currently in an unusable state.

#2

Updated by Ruben Schmidmeister over 5 years ago

This problem only seems to occur with maxitems set.

In my tests (with sys_category) I encountered the following situations:

- maxitems: 1
1 item is selectable, but a exclamation mark appears when selected. When unselected, no item is selectable.

- maxitems: 2
1 item is selectable, if the tree is loaded with 1 item preselected 2 items are selectable.

- maxitems: 3
2 items are selectable, if the tree is loaded with 1 or more items preselected 3 items are selectable.

- maxitems: n
(n -1) items are selectable, if the tree is loaded with 1 or more items preselected n items are selectable.

(If the tree is loaded with some items preselected and all items are deselected n - 1 items are selectable).

#3

Updated by Alexander Bigga over 5 years ago

I encountered the same issue. This issue is caused by fix for #75519 (Flexform select rendermode tree doesn't respect collapsed nodes).

I've just made a oneline patch and will commit it in the next minutes.

#4

Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47937

#5

Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47940

#6

Updated by Oliver Hader over 5 years ago

  • Target version set to next-patchlevel
  • Is Regression changed from No to Yes
#7

Updated by Christian Kuhn over 5 years ago

  • Sprint Focus set to Stabilization Sprint
#8

Updated by Christian Kuhn over 5 years ago

  • Target version changed from next-patchlevel to 8.1
#9

Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/47971

#10

Updated by Anonymous over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF