Bug #76188

Exception at I do not use MySQL

Added by Alexander Averbuch over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2016-05-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
dbal, doctrine
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Hello All!

In the version 8.1, if I select in the Install tool "I do not use MySQL", I get the exception

#1166546734: Package "adodb" is not available. Please check if the package exists and that the package key is correct (package keys are case sensitive). (More information)

TYPO3\CMS\Core\Package\Exception\UnknownPackageException thrown in file
C:\projects\typo3eight1\typo3\sysext\core\Classes\Package\PackageManager.php in line 508.

I use XAMPP v3.2.2 with PHP 7.0.4
In include_path stands the path include_path=".;C:\xampp\php\pear"


Related issues

Related to TYPO3 Core - Task #73041: Only show active packages in PackageStates.phpClosedBenni Mack2016-01-30

Actions
#1

Updated by Frank Naegler over 5 years ago

  • Status changed from New to Accepted
  • Is Regression changed from No to Yes

confirmed with current master, thanks for your report.

I suggest it is related to the doctrine patch. We will investigate the issue.

#2

Updated by Frank Naegler over 5 years ago

\TYPO3\CMS\Install\Controller\Action\Step\DatabaseConnect::executeLoadDbalExtension tries to load EXT:adodb and EXT:dbal which not work and produce the exception.
No idea yet why it happens.

#3

Updated by Morton Jonuschat over 5 years ago

This is caused by commit 077d5d9071df5f0b5df7217e2402b0eebe4017dd for issue #73041

#4

Updated by Morton Jonuschat about 5 years ago

  • Category set to Install Tool
  • Status changed from Accepted to Closed

dbal/adodb have been removed from the core - this problem does not occur anymore. The selection of the database in the install tool will be rewritten to provide the option to select alternative database next.

Also available in: Atom PDF