Bug #76274


Translate Button does not work when no Access to Default language

Added by nel bar about 8 years ago. Updated about 5 years ago.

Must have
Target version:
Start date:
Due date:
% Done:


Estimated time:
TYPO3 Version:
PHP Version:
Is Regression:
Sprint Focus:


As a backend user with access to only 1 language the Translate-Button in the Page View does not work when the backend user have no rights for the default language (or any language from where the content is copied from).

The Translate button is there and the user can click it and select copy. No Errors are displayed. But the content does not get copied at all.
In the log the following message comes:
Attempt to copy record without having permissions to do so. [ERROR: Language was not allowed.].
Attempt to insert a record on page '[root-level]' (0) from table 'tt_content' without permissions. Or non-existing page. (msg#1.1.12)

Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Story #101564: User Interface related translation issuesNew2023-08-03

Has duplicate TYPO3 Core - Story #75699: i dont want to see the button "Translate" when i am not allowed to translate the content elementsClosed2016-04-15

Actions #1

Updated by Wouter Wolters about 8 years ago

  • Target version deleted (7.6.5)
Actions #2

Updated by Mona Muzaffar about 7 years ago

  • Has duplicate Story #75699: i dont want to see the button "Translate" when i am not allowed to translate the content elements added
Actions #3

Updated by Riccardo De Contardi about 5 years ago

I tried the following test with TYPO3 9.5.8


  • Fresh TYPO3 installation with three additional languages:
    • Italian (Default)
    • English (ID=1)
    • French (ID=2)
    • German (ID=4)
  • All the languages are configured in "Sites" Module
  • BE usergroup with
    • ACL: all fields, all tables selected
    • Limit to Languages (allowed_languages): select only English and German
  • Be user, assigned to the previous BE usergrop

Test Execution

  • create a "Test" page
  • translate it into all languages
  • create two content elements in Default language
  • translate only the first content element into all languages
    • I always used "Translate" mode
    • I always used Default as "starting" language
  • make sure that "Editors" can see and edit the page
  • switch user to "Editor"
  • go to "Test" page

Test Results

in Page > "Languages" view

  • the Editor can see Default, English and German "columns"
  • The Default "column" cannot be edited, no "pencil" visible;
    • this is also valid if you switch to "column" view: "Default" is selectable, but cannot be edited.
    • you can still edit the page title with the pencil that pops up near it, but it leads to an error (shown twice):
1: recordEditAccessInternals() check failed. [ERROR: Language was not allowed.]
  • It is possible to use the "translate" button, but the translation workflow does not complete! It is stuck at step 3 of 4!

I also tried with the following scenarios

  • use "Copy" mode instead of "Translate" mode
  • translate the first content element in German from English

but the result is the same, the translation does not finish.

Actions #4

Updated by leon jänicke 12 months ago

  • Related to Story #101564: User Interface related translation issues added

Also available in: Atom PDF