Bug #76519

Extbase not respecting l10n_mode = mergeIfNotBlank for mm relations

Added by Ruben Schmidmeister over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2016-06-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Suppose we have the following field declaration in our TCA (taken from the news extension):

 'categories' => [
    'exclude' => 1,
    'l10n_mode' => 'mergeIfNotBlank',
    'label' => $ll . 'tx_news_domain_model_news.categories',
    'config' => [
        'type' => 'select',
        'renderType' => 'selectTree',
        'treeConfig' => [
            'dataProvider' => \GeorgRinger\News\TreeProvider\DatabaseTreeDataProvider::class,
            'parentField' => 'parent',
            'appearance' => [
                'showHeader' => true,
                'allowRecursiveMode' => true,
                'expandAll' => true,
                'maxLevels' => 99,
            ],
        ],
        'MM' => 'sys_category_record_mm',
        'MM_match_fields' => [
            'fieldname' => 'categories',
            'tablenames' => 'tx_news_domain_model_news',
        ],
        'MM_opposite_field' => 'items',
        'foreign_table' => 'sys_category',
        'foreign_table_where' => ' AND (sys_category.sys_language_uid = 0 OR sys_category.l10n_parent = 0) ORDER BY sys_category.sorting',
        'size' => 10,
        'autoSizeMax' => 20,
        'minitems' => 0,
        'maxitems' => 99,
    ]
],

Let's say I have a news entry in the default langauge with some categories selected.
Now I translate that news to let's say french.

In my translation no categories are selected, which is correct because of mergeIfNotBlank.
But when I look at the categories of the translated Article from Fluid or my Extbase controller they're empty when they should inherit from the Article in the default language.

If I add some categories to my translated Article naturally those are shown in the frontend.

Btw: I have tried with both translated categories and with language set to [ALL]


Related issues

Is duplicate of TYPO3 Core - Bug #62921: l10n_mode with relations does not work in ExtbaseClosed2014-11-13

Actions
#1

Updated by Daniel Goerz over 5 years ago

  • Status changed from New to Closed

As agreed upon on slack, I close this ticket as duplicate of #62921. Please continue the discussion over there.

Also available in: Atom PDF