Bug #76629

Assigning translated categories doesn't work

Added by nurbs999 no-lastname-given over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2016-06-14
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
category, translation, pages
Complexity:
Is Regression:
No
Sprint Focus:

Description

Assigning categories to pages doesn't save the translation of the category.

Steps to reproduce:
Create new page language
Create sys_folder for categories
Create new category "cat_01"
Create translation for category "cat_01" => "cat_01_de"

At this point the database has two categories with IDs '1' and '2' in table 'sys_category'

Create new page "category_index"
Assign "cat_01" to page "category_index"

At this point the database has only one entry in 'sys_category_record_mm' for the default language. But it should have both relations. One for 'cat_01' and one for 'cat_01_de' since this is just a translation.

Now, if you try to get the translated category via typoscript like this:

table = sys_category
select {
languageField = sys_language_uid
pidInList = 2
join = sys_category_record_mm ON sys_category_record_mm.uid_local = sys_category.uid
where.data = field:uid
where.intval = 1
where.wrap = sys_category_record_mm.uid_foreign=|
orderBy = sys_category.sorting
}

it works for the default language, but you get zero results for the translation.


Related issues

Related to TYPO3 Core - Bug #70460: Categories for translated pages/categories get lost New 2015-10-07
Related to TYPO3 Core - Bug #61923: Localization of elements and their categories in the backend Accepted 2014-09-27
Related to TYPO3 Core - Bug #68177: Wrong Categories on pages with pages_language_overlay Closed 2015-07-15

History

#1 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from New to Closed

I close this one in favor of #70460 please continue the discussion there. I've added there the description of this issue to keep track of it.

Also available in: Atom PDF