Bug #68177

Wrong Categories on pages with pages_language_overlay

Added by Alexander Krist over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Categorization API
Target version:
-
Start date:
2015-07-15
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

We configured categories for pages and pages_language_overlay.

And now there is a problem with determining the category for a page with a language overlay.

We have a page X with an overlay Y. In our rootline we found the categories for page Y. But what we need are the categories for overlay Y.

Er located the problem in RootlineUtility.php:277-284

                    $loadDBGroup->start(
                        $pageRecord[$column],
                        isset($configuration['allowed']) ? $configuration['allowed'] : $configuration['foreign_table'],
                        $configuration['MM'],
                        $uid,
                        'pages',
                        $configuration
                    );
<pre>

There is @'pages'@ in code. For overlays it should be @'pages_language_overlay'@.

But this is not enough to fix the issue.

Related issues

Related to TYPO3 Core - Bug #70460: Categories for translated pages/categories get lost New 2015-10-07
Related to TYPO3 Core - Bug #61923: Localization of elements and their categories in the backend Accepted 2014-09-27
Related to TYPO3 Core - Bug #76629: Assigning translated categories doesn't work Closed 2016-06-14
Duplicates TYPO3 Core - Feature #66155: Backend display of localized records New 2015-03-30

History

#1 Updated by Riccardo De Contardi about 3 years ago

  • Category set to Categorization API

#2 Updated by Oliver Hader about 2 years ago

  • Complexity changed from medium to hard

#3 Updated by Susanne Moog about 1 year ago

  • Sprint Focus set to On Location Sprint

#4 Updated by Susanne Moog about 1 year ago

  • Duplicates Feature #66155: Backend display of localized records added

#5 Updated by Susanne Moog about 1 year ago

  • Status changed from New to Closed

Closed as duplicate of #66155

Also available in: Atom PDF