Bug #76676

Localization overview show blank page when clicking on "create new translation headers"

Added by Tymoteusz Motylewski over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-06-17
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Go to info -> localization overview
and click on the button called "create new translation headers".
You will see a blank page with toolbar.

See attached screenshots.
Tested on 7.6.9 and 6.2.

empty-page.png View (13.6 KB) Tymoteusz Motylewski, 2016-06-17 11:58

localization overview.png View (31.1 KB) Tymoteusz Motylewski, 2016-06-17 11:58

Associated revisions

Revision 895ec997 (diff)
Added by Oskar Dydo over 1 year ago

[BUGFIX] Disable "Create new translation headers" when no selection is made

The "Create new translation headers" is now disabled if no page to be
translated is selected to avoid errors in the target action. A small
TypeScript is added that unlocks the aforementioned button if at least
one checkbox was selected.

Resolves: #76676
Releases: master, 8.7
Change-Id: I163ed7322066d81597547dd2b2774434a086f082
Reviewed-on: https://review.typo3.org/56441
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Riccardo De Contardi <>
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Kay Strobach <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision a6e91c83 (diff)
Added by Andreas Fernandez over 1 year ago

[BUGFIX] Disable "Create new translation headers" when no selection is made

The "Create new translation headers" is now disabled if no page to be
translated is selected to avoid errors in the target action. A small
TypeScript is added that unlocks the aforementioned button if at least
one checkbox was selected.

Resolves: #76676
Releases: master, 8.7
Change-Id: I163ed7322066d81597547dd2b2774434a086f082
Reviewed-on: https://review.typo3.org/56734
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Riccardo De Contardi over 3 years ago

Tymoteusz, I think that the problem is that you have to check what pages you want to translate before clicking that button, can you confirm?

There is a UX problem here: that button should be disabled until at least one checkbox is checked.

#2 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#3 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#4 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#5 Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#6 Updated by Gerrit Code Review over 1 year ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#7 Updated by Gerrit Code Review over 1 year ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#8 Updated by Gerrit Code Review over 1 year ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#9 Updated by Gerrit Code Review over 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#10 Updated by Gerrit Code Review over 1 year ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#11 Updated by Gerrit Code Review over 1 year ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#12 Updated by Gerrit Code Review over 1 year ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56441

#13 Updated by Oskar Dydo over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Gerrit Code Review over 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56734

#15 Updated by Andreas Fernandez over 1 year ago

  • Status changed from Under Review to Resolved

#16 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF