Bug #76688

Error in Ext:form: Section "main" does not exist

Added by Wolfgang Wagner about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2016-06-17
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Using ext:form in combination with causes an uncaught exception in the frontend: The Section "main" does not exist.

http://www.awesomescreenshot.com/image/1329902/ff3af82e283117e318330a61312552df

To solve this problem, I had to rename all sections main to Main in the templates, and the render viewhelper in the layout file must be adjusted too.

(TYPO3 Master, 8.2.0-dev)


Related issues

Duplicates TYPO3 Core - Bug #76675: Layout Filename must be unique or frontend crashes Closed 2016-06-17

History

#1 Updated by Morton Jonuschat about 3 years ago

  • Status changed from New to Closed

Closed as duplicate of #76675

#2 Updated by Wolfgang Wagner about 3 years ago

Sure this is a duplicate? Same error message, but different solution and maybe a different reason?

#3 Updated by Bjoern Jacob about 3 years ago

Let's see if #76675 fixes this problem too. If not we can still re-open this issue here.

#4 Updated by Bjoern Jacob about 3 years ago

  • Category set to Form Framework

#5 Updated by Tashko Valkov over 1 year ago

Working solution: Just delete the 3 rows from your template:
--------------
<f:layout name="Default" />

<f:section name="main">
...
</f:section>
--------------

if you don't use them and your template works without them.

Tested and works in Typo3 8.5.1 and DCE 1.5.2 (which was upgraded from 1.4.8 and this reason caused this issue)

Also available in: Atom PDF