Bug #76675

Layout Filename must be unique or frontend crashes

Added by martin no-lastname-given about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Category:
Form Framework
Target version:
Start date:
2016-06-17
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Apparently, if you use a Layout called "Default.html" and use the Form-Plugin on a page, the page will crash with the error message "Section "main" does not exist". After renaming the local Layout, the issues resolves. This appears to be a problem with generation of cached Layouts and their filenames.


Related issues

Related to TYPO3 Core - Bug #79760: FLUIDTEMPLATE not rendered when Layout name collides with Layout name of FSC Closed 2017-02-11
Related to TYPO3 Core - Bug #82745: fluid resolving an unexpected layout file Closed 2017-10-12
Duplicated by TYPO3 Core - Bug #76688: Error in Ext:form: Section "main" does not exist Closed 2016-06-17

History

#1 Updated by Daniel Goerz about 3 years ago

  • Sprint Focus set to Stabilization Sprint

#2 Updated by Benni Mack about 3 years ago

  • Target version changed from 8.2 to 8.3

#3 Updated by Bjoern Jacob about 3 years ago

  • Category changed from Fluid to Form Framework
  • Status changed from New to In Progress
  • Assignee set to Bjoern Jacob
  • Sprint Focus changed from Stabilization Sprint to On Location Sprint

#4 Updated by Bjoern Jacob about 3 years ago

  • Status changed from In Progress to Needs Feedback
  • Assignee changed from Bjoern Jacob to martin no-lastname-given

The problem is known and it should be fixed with the current master of fluid. Does this problem also occur with TYPO3 v7? Yesterday, I've spent some time to reproduce the problem. Could you please supply me some more information of your setup? Does it happen as soon as your FLUIDTEMPLATE is named "Default.html" or does it happen in confluence with another extension like yag (which also ships with a layout called "Default.html")?

#5 Updated by Wolfgang Wagner about 3 years ago

Seems to work now in 8.3.0-dev now.

#6 Updated by Riccardo De Contardi almost 3 years ago

unable to reproduce on 8.3-dev (latest master)

#7 Updated by Benni Mack almost 3 years ago

  • Target version changed from 8.3 to 8.4

#8 Updated by Benni Mack almost 3 years ago

  • Target version changed from 8.4 to 8.5

#9 Updated by Wouter Wolters almost 3 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#10 Updated by Clemens Riccabona almost 2 years ago

  • Related to Bug #79760: FLUIDTEMPLATE not rendered when Layout name collides with Layout name of FSC added

#11 Updated by Peter Niederlag almost 2 years ago

  • Related to Bug #82745: fluid resolving an unexpected layout file added

#12 Updated by Tashko Valkov over 1 year ago

Working solution: Just delete the 3 rows from your template:
--------------
<f:layout name="Default" />

<f:section name="main">
...
</f:section>
--------------

if you don't use them and your template works without them.

Tested and works in Typo3 8.5.1 and DCE 1.5.2 (which was upgraded from 1.4.8 and this reason caused this issue)

#13 Updated by Mathias Brodala over 1 year ago

  • Sprint Focus deleted (On Location Sprint)

Also available in: Atom PDF