Bug #76729

Link to file's metadata does not work in full window

Added by Gleb Levitin over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2016-06-22
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Metadata editing for file references works only within iframe (regular behavior).
If content element is opened in a full window, it's not more possible to navigate to file's metadata via appropriate icon.

full_window.png View (67.7 KB) Gleb Levitin, 2016-06-24 09:44

Associated revisions

Revision 8a9bc017 (diff)
Added by Wouter Wolters over 3 years ago

[BUGFIX] Fix link to edit file metadata in full window

When opening a window with a file reference in a full window
it is not possible to click the edit metadata button.

Use a normal href to avoid the issue with choosing the correct frame.

Resolves: #76729
Releases: master,7.6
Change-Id: Iaa140f28104782870c50ef0d876e472067a09fed
Reviewed-on: https://review.typo3.org/48667
Tested-by: Bamboo TYPO3com <>
Reviewed-by: Michael Oehlhof <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Frederic Gaus <>
Tested-by: Frederic Gaus <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision b0aeb228 (diff)
Added by Wouter Wolters over 3 years ago

[BUGFIX] Fix link to edit file metadata in full window

When opening a window with a file reference in a full window
it is not possible to click the edit metadata button.

Use a normal href to avoid the issue with choosing the correct frame.

Resolves: #76729
Releases: master,7.6
Change-Id: Iaa140f28104782870c50ef0d876e472067a09fed
Reviewed-on: https://review.typo3.org/49225
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Wouter Wolters over 3 years ago

  • Status changed from New to Needs Feedback

Can you please add a screenshot at which module and location you are?

#2 Updated by Gleb Levitin over 3 years ago

Screenshot added.

#3 Updated by Wouter Wolters over 3 years ago

  • Status changed from Needs Feedback to Accepted

Thanks. I see it does not work on my machine as well.

#4 Updated by Wouter Wolters over 3 years ago

Clicking on this button is prevented because top.content.list_frame is not available when opening the frame in a new tab.
I don't have a solution for that yet. There are places in TYPO3 that raise a JS issue when clicking on such a button.

#5 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48667

#6 Updated by Daniel Goerz over 3 years ago

  • Sprint Focus set to Stabilization Sprint

#7 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48667

#8 Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49225

#9 Updated by Wouter Wolters over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF