Bug #77830

fluid_styled_content: Standard header doesn't use PAGE_TARGET

Added by Arnd Messer about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2016-09-03
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

If you set the option "styles.content.links.target" in the Constants, it will not change the link target for header links.

Tested with TYPO3 8.4.0-dev


Related issues

Related to TYPO3 Core - Bug #36216: css_styled_content: Standard header doesn't use PAGE_TARGET Closed 2012-04-17

Associated revisions

Revision 63196700 (diff)
Added by Arnd Messer almost 3 years ago

[BUGFIX] Remove styles.content.links.target

Remove styles.content.links.target from constants.txt and
lib.parseFunc.ts.

styles.content.links.target has as description in constants.txt pointing
the value is used for frames.

Since fluid_styled_content is focussing on HTML5, this value does not
make sense at all, since frames have been removed from the
specification.
styles.content.links.target should be removed from constants.txt in
fluid_styled_content including the use of this constant value in
lib.parseFunc.ts, the only place where it is used. The typolink
viewhelper does not take this into account also.

Resolves: #77830
Related: #36216
Releases: master
Change-Id: I16e8dc3f77595fde20d8c43d6ab16eb7d590e34b
Reviewed-on: https://review.typo3.org/49839
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Patrick Broens about 3 years ago

styles.content.links.target has as description in constants.txt pointing the value is used for frames:

"Target for internal links: Should match the name of the content PAGE-object in TypoScript when used with frames. Most cases: set to "" (empty). If you have frames in the template set to "page""

Since fluid_styled_content is focussing on HTML5, this value does not make sense at all, since frames have been removed from the specification.

styles.content.links.target should be removed from constants.txt in fluid_styled_content including the use of this constant value in lib.parseFunc.ts, the only place where it is used. The typolink viewhelper does not take this into account also.

#2 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49839

#3 Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49839

#4 Updated by Benni Mack almost 3 years ago

  • Target version changed from 8.4 to 8.5

#5 Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49839

#6 Updated by Arnd Messer almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF