Bug #77873

Missing crossorigin property for JavaScript files (SRI)

Added by Mathias Brodala over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Category:
Frontend
Target version:
Start date:
2016-09-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Using SRI to ensure the integrity of JavaScript resources works fine for local content. However, for JavaScript resources added e.g. via CDN a CORS request will be performed which will fail by default.

This can be fixed with the crossorigin="anonymous", thus this attribute must be supported when including JavaScript files.


Related issues

Related to TYPO3 Core - Feature #66698: Add integrity property to JavaScript filesClosedXavier Perseguers2015-05-01

Actions
Is duplicate of TYPO3 Core - Feature #76459: Add crossorigin property to JavaScript filesClosedJacob Dreesen2016-06-05

Actions
#1

Updated by Mathias Brodala over 4 years ago

  • Status changed from New to Closed

Duplicate of #76459

Also available in: Atom PDF