Project

General

Profile

Actions

Task #77987

closed

Deprecated record listing in page module

Added by Georg Ringer almost 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2016-09-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Rendering of records in the page module should be removed because of the following reasons:

  • Its functionality belongs to the list module
  • It duplicates functionality
Actions #1

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49968

Actions #2

Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49968

Actions #3

Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49968

Actions #4

Updated by Georg Ringer almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Riccardo De Contardi almost 7 years ago

  • Status changed from Resolved to Closed
Actions #6

Updated by Christian Weiske over 3 years ago

I know the issue is old and I will not change anything, but:

We used this functionality to ease editing for people that use typo3 once in a month to edit their single page and two custom records.
Making the list of custom records available on the "page" module meant that they did not have to have access to the list view (which would confuse them), and it made editing those records much easier.

Now they have to get access to the list module, scroll through the dozen of content records to find the one custom table record they want to edit.

Actions

Also available in: Atom PDF