Bug #78259

Using page alias instead of uid as argument for pageUid attribute broken in FormViewHelper

Added by Jacob Dreesen almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2016-10-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The fix for #77793 broke the previous behaviour that allowed to use a page alias (string) instead of a uid (integer) as argument for the pageUid attribute

It is possible to use the page alias everywhere else (because the typolink definition allows to use the page alias instead of the uid) and thus I think it should be fixed in the FormViewHelper.

#1

Updated by Claus Due almost 5 years ago

If this worked before it is by coincidence. The argument type for `pageUid` was `int` also before the linked patch and as such it should not support string values. So I lean towards calling this "unsupported usage" and closing this bug report (since technically this is no bug).

On the other hand you might want to open a feature request to allow `mixed` as type of the argument and some further checking instead of assuming it is an integer. However, that would constitute a FEATURE (API change) and would not be accepted into the 7.6 branch.

#2

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Closed

I close this issue - see previous comment for the explanation

if you think that this is the wrong decision, please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF