Bug #78355

System > Access module not starting in selected page of page tree

Added by Patrick Broens 11 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2016-10-20
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When selecting a page in the page tree, and going to the System > Access module, it will always start at the root page of the website, not the selected one. This is confusing for people maintaining these access rights. When you have entered the module and select a page again, the Access module will switch to this page.

How to reproduce:
  • Open the page module and select a page in the page tree which is not the web root page
  • Go to the module System > Access
  • This module will open with the web root page, not the selected one
  • When clicking the selected page again in the page tree, it will show the access rights for this page

Other modules, which use the page tree, are fine, like the Page or List. When opening these modules after the use of another one, they will continue on the same page, like selected in the page tree.

Associated revisions

Revision 078107e4 (diff)
Added by Michael Oehlhof 4 months ago

[BUGFIX] System > Access module now starting in selected page of page tree

Resolves: #78355
Releases: master
Change-Id: Ibf4966f312124bdab38701e014cd9fd74f768adf
Reviewed-on: https://review.typo3.org/51044
Tested-by: TYPO3com <>
Reviewed-by: Gianluigi Martino <>
Tested-by: Gianluigi Martino <>
Tested-by: Riccardo De Contardi <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Riccardo De Contardi 11 months ago

also on 8.5.0-dev

#2 Updated by Daniel Windloff 11 months ago

It seems to be kind of regression introduced by #62339 (Move access module from web > access to system > access), because the additional id parameter depends on the current section (e.g. web, file, system).
See

typo3/sysext/backend/Resources/Public/JavaScript/modulemenu.js:200

includeId: function (mod, params) {
    if (typeof mod === 'undefined') {
        return params;
    }
    //get id
    var section = mod.split('_')[0];
    if (top.fsMod.recentIds[section]) {
        params = 'id=' + top.fsMod.recentIds[section] + '&' + params;
    }
    return params;
},

As different values are used for web or file, I would opt for the introduction of a new identifier and remove the dependency of the current section. This would solve the issue.

#3 Updated by Michael Oehlhof 9 months ago

  • Assignee set to Michael Oehlhof

#4 Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51044

#5 Updated by Michael Oehlhof 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF