Bug #78555

"Add media by URL" does not work on our Servers

Added by Stefan Froemken over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2016-11-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

we are currently working with TYPO3 8.4 and activated fluid_styled_content.

While editing/creating a content element of type "Text/Media" we have the possibility to "Add media by URL". After inserting a link to YouTube and clicking on "Add" a new media record was created, but the preview image is grey with the text: "File not found". Further the YouTube-ID is missing in the path of the iframe in FE. So video can't be started.

The problem seems to be in the path generation. You create a temporary path with GeneralUtility::tempname which will result in "/kunden/..." on our Servers. But the content of PATH_site is "/www/...". While checking them against each other in GeneralUtility::writeFileToTypo3tempDir following line will be returned:

return '"' . $fI['dirname'] . '" was not within directory PATH_site + "typo3temp/"';

On our servers /www is a symlink to /kunden. So it would be good to read the target of symlink of PATH_site before checking them against the result of tempnam().

Stefan


Related issues

Is duplicate of TYPO3 Core - Bug #70106: Temporary files are not deleted even though GeneralUtility::unlink_tempfile is calledClosed2015-09-25

Actions
#1

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50490

#2

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50490

#3

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50490

#4

Updated by Helmut Hummel about 4 years ago

  • Status changed from Under Review to Closed

closed as duplicate

Also available in: Atom PDF