Project

General

Profile

Actions

Bug #78558

closed

Story #69617: FormEngine bugs

Suggest wizard does not initialize correctly in flex form sections

Added by Christian Kuhn over 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2016-11-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

suggest wizard in flex form sections does not work for existing sections,
only in newly added ones.

tx_styleguide_elements_group, flex_1, third tab:

  • Add a new section: suggest wizard works
  • select something
  • save record
  • -> suggest wizard of this section no longer works
  • add another section -> suggest wizard of that new section is ok

I'd guess that's some initialization issue in JS?

Actions #1

Updated by Christian Kuhn over 7 years ago

That's not a bug in JS.

Instead, that's an issue in SuggestWizard "isRelevantFlexField": A persisted container has a numeric id, but the method checks for "ID-" stuff of new container only.

Example new container string:
flex_1|data|sSuggestCheckCombination|lDEF|settings.subelements|el|ID-356586b0d3-idx1478611729574-form|item|el|content|vDEF
After save:
flex_1|data|sSuggestCheckCombination|lDEF|settings.subelements|el|1|item|el|content|vDEF

Somehow, this method needs to be smarter ... all this "isRelevantFlexField" stuff sounds a bit fishy, anyway.

Actions #2

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50839

Actions #3

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50839

Actions #4

Updated by Christian Kuhn about 7 years ago

  • TYPO3 Version changed from 7 to 8
  • Sprint Focus changed from Stabilization Sprint to On Location Sprint
Actions #5

Updated by Christian Kuhn about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF