Bug #78783

CE Special/Menu type "directory" sorting

Added by Nando Bosshart over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Fluid Styled Content
Target version:
-
Start date:
2016-11-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If CE "Special/Menu" -> "Sitemap of these pages" is used, the frontend-rendering of selected pages is overall sorted by "sorting", which seems an expected behaviour at first.

BUT:
If multiple pages are selected (for example you want a combined main-navigation with meta-navigation in one sitemap) and you sort those pages manually in the "pages" field, the sorting is ignored in the frontend and the whole sitemap is sorted by "sorting" overall, which mixes up the desired order of selected pages.

example site-structure:
-PID:1
---PID:10
------PID:17
------PID:19
------PID:18
---PID:9
-PID:4
---PID:14
---PID:102
---PID:103
-PID:2
---PID:23
---PID:104

assigned & sorted "Special/Menu" pages in backend:
-PID:1
-PID:2
-PID:4

expected frontend-sorting:
---PID:10
------PID:17
------PID:19
------PID:18
---PID:9
---PID:23
---PID:104
---PID:14
---PID:102
---PID:103

actual sorting:
---PID:14
---PID:23
---PID:102
---PID:104
---PID:103
---PID:10
------PID:17
------PID:19
------PID:18
---PID:9

the actual sorting is determined by "sorting" in typo3/sysext/fluid_styled_content/Classes/ViewHelpers/Menu/DirectoryViewHelper.php line 78 but from my point of view it should also consider the case when multiple PIDs are assigned AND manually sorted in the pages field .

This bug is basically the same issue as here, but solution seems way more complex (if possible at all):
[[https://forge.typo3.org/issues/71044]]


Related issues

Related to TYPO3 Core - Bug #71044: CE Special/Menu Order by IDClosedBenni Mack2015-10-26

Actions
Related to TYPO3 Core - Task #79622: Streamline CSS Styled Content and Fluid Styled ContentClosed2017-02-28

Actions
#1

Updated by Susanne Moog over 1 year ago

  • Status changed from New to Closed

This has been fixed with https://forge.typo3.org/issues/71044 basically since the menus are now build via the data processors using the same logic.

Also available in: Atom PDF