Bug #78824

TCA select renderType=selectCheckBox allows only one value to be saved

Added by Anja Leichsenring over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2016-11-28
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Reproducable with ext:styleguide, table elements select, the fields accept only one value to be selected. After saving, the lowest value has been put into database.

According logical expectation, and https://docs.typo3.org/typo3cms/TCAReference/Reference/Columns/Select/Index.html#rendertype too, the field should be able to hold multiple values.

Associated revisions

Revision 38a1bc5d (diff)
Added by Christian Kuhn over 2 years ago

[!!!][TASK] Improve flex and TCA handling in FormEngine

The patch adapts a series of nasty form engine areas to more solid
code. The evaluate condition code is rewritten and works much better
in flex form scenarios. The suggest wizard and svg tree are much
more solid in flex forms. The group element is rewritten
towards a better readable and easier to refactor code, dropping
method dbFileIcons(). A bunch of issues is resolved along the way.

  • TCA "default" now works in flex form section container elements
  • The "displayCond" parser is now strict and throws exceptions on
    invalid syntax and wrong referenced fields to help debugging
    faulty display conditions
  • TCA displayCond on flex fields can now be prefixed with the
    sheet name and can reference field values from neighbor sheets
  • TCA displayCond now works with flex section containers
  • TCA flex section container now throw an exception if select or
    group fields configure a MM relation - this is not supported
  • TCA ctrl requestUpdate field is dropped, onChange=reload is now allowed
    not only on flex form fields, but also on normal columns fields
  • TCA tree now works as section container element and initializes
    correctly on new records and new containers
  • GroupElement rewrite to drop dbFileIcons()
  • config option maxitems now optional for type=group and type=select
    and defaults to "many items allowed"
  • inline now works in "fancy" flex situations with "new" records
    by handing the final dataStructureIdentifier around
  • FormEngine no longer loads extJS

Change-Id: Id1d081627529cc1502bb198389e5bd69372815cd
Resolves: #78899
Resolves: #72307
Resolves: #75646
Resolves: #76637
Resolves: #72106
Resolves: #78824
Resolves: #76793
Resolves: #68247
Resolves: #69715
Related: #78460
Related: #67198
Related: #72294
Releases: master
Reviewed-on: https://review.typo3.org/50879
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Anja Leichsenring over 2 years ago

  • Status changed from New to Rejected

it has been discovered, that this is the intended behaviour. If one wants to select multiple values, the maxitems config option has to be set to something larger than 1.

Thanks Christian for explanation and update of ext:styleguide.

#2 Updated by Christian Kuhn over 2 years ago

  • Status changed from Rejected to New

#3 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 39 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 40 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 41 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 42 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#7 Updated by Gerrit Code Review over 2 years ago

Patch set 43 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#8 Updated by Gerrit Code Review over 2 years ago

Patch set 44 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#9 Updated by Gerrit Code Review over 2 years ago

Patch set 45 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#10 Updated by Gerrit Code Review over 2 years ago

Patch set 46 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#11 Updated by Gerrit Code Review over 2 years ago

Patch set 47 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#12 Updated by Gerrit Code Review over 2 years ago

Patch set 48 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50879

#13 Updated by Christian Kuhn over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF