Task #78881

Improve bookmark / shortcut handling (ShortcutToolbarItem)

Added by Alexander Stehlik over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-12-04
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
medium
Sprint Focus:

Description

  • When a new bookmark is created the bookmark button is in an invalid state (should become yellow after the bookmark was created).
  • When the current record is deleted from the bookmarks the bookmark button should become active again without having to reload the page.
  • New bookmarks are in no group by default. But there is no entry "no group" in the list of bookmark groups. As soon as the bookmark is changed it will be put in a group automatically. Two possible solutions:
    1. Always create new bookmarks in a default group
    2. Add a "no group" entry to the list of bookmark groups in the edit form

Related issues

Related to TYPO3 Core - Bug #75689: Create a bookmark after delete a bookmark is blocked Accepted 2016-04-15

History

#1 Updated by Riccardo De Contardi over 2 years ago

  • Related to Bug #75689: Create a bookmark after delete a bookmark is blocked added

#2 Updated by Susanne Moog about 1 year ago

  • Status changed from New to Closed

Tested this issue and aside from the related issue I cannot reproduce the other two things. Please reopen or report a new issue if these errors persist in current TYPO3 versions.

Also available in: Atom PDF