Bug #78897

file references consider wrong language uid for metadata

Added by Anja Leichsenring almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2016-12-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This all goes in BE (FormEngine):

Szenario:
- Image in filadmin, sys_file_metadata record in default language, title field filled.
- Translate sys_file_metadata record to any language, title field contains translated data
- Create tt_content record in default language, reference the image.

--> title field to be overridden by sys_file_reference field title contains the translated value, not the one from sys_file_metadata in default language.


Related issues

Related to TYPO3 Core - Bug #76048: IRRE: Child records - New record doesn't get language of parent (non localized records but using new button)ClosedJo Hasenau2016-05-04

Actions
Is duplicate of TYPO3 Core - Bug #75040: placeholder pointing to column of related record shows values from wrong languageClosed2016-03-14

Actions
#1

Updated by Anja Leichsenring almost 5 years ago

some tries with creation order turned out, that always the latest created sys_file_metadata record is used.

#2

Updated by Helmut Hummel over 4 years ago

  • Related to deleted (Bug #75040: placeholder pointing to column of related record shows values from wrong language)
#3

Updated by Helmut Hummel over 4 years ago

  • Is duplicate of Bug #75040: placeholder pointing to column of related record shows values from wrong language added
#4

Updated by Helmut Hummel over 4 years ago

  • Status changed from New to Closed

closed as duplicate

Also available in: Atom PDF