Bug #78919

Avoid no_cache=1 after "Save and view page"

Added by Christian Toffolo almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-12-08
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When an editor clicks on "Save and view page" a new tab opens with a link like:
http://www.domain.ext/index.php?id=2&no_cache=1
if the editor shares this page we will have an incorrect link living in the internet.

At least remove the no_cache=1 parameter that is not necessary because the cache should be cleared while saving the page and not with the parameter.
Also it would be better to have the speaking url instead of "index.php?id=2" but probable this should be handled by the speaking url generator extension (ex. realurl).


Related issues

Related to TYPO3 Core - Bug #78336: Avoid usage of no_cache in preview link configuration Closed 2016-10-18

History

#1 Updated by Georg Ringer almost 3 years ago

  • Status changed from New to Closed

Closed as duplicate, see related issue

Also available in: Atom PDF