Bug #78336

Avoid usage of no_cache in preview link configuration

Added by Josef Glatz about 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2016-10-18
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Problem/Description

#66370 introduced the flexible link configuration for pre-/viewing records in the frontend.
Actually, the FE\disableNoCacheParameter needs to be false, as no_cache is always added.

ToDo(s)

  • Add cHash calculation for generating the frontend url.
  • Once this is merged - the documentation must be also adopted. The info about the no_cache stuff is possible.
  • Also a breaking change rst document could be beneficial

Master/7.6


Related issues

Related to TYPO3 Core - Task #66370: Add generic preview URL generator API Closed 2015-04-10
Related to TYPO3 Core - Bug #78919: Avoid no_cache=1 after "Save and view page" Closed 2016-12-08
Related to TYPO3 Core - Bug #81297: Extbase record preview leads to 404 due to missing cHash Closed 2017-05-22
Duplicated by TYPO3 Core - Bug #81417: Record preview leads to error &cHash empty Closed 2017-06-02

Associated revisions

Revision 0aa5f2b4 (diff)
Added by Georg Ringer almost 2 years ago

[BUGFIX] Make it possible to add cHash to preview links

It must be possible to generate preview URLs with a cHash, e.g. to
display records using Extbase which enforces cHash usage.

Introduce a new option "useCacheHash" which triggers cHash calculation.
If not specified, the "no_cache" parameter is added just like before.

Resolves: #78336
Resolves: #81297
Releases: master, 8.7
Change-Id: I225e2b8b4355022e7b4f6866c989b707e526e389
Reviewed-on: https://review.typo3.org/50264
Reviewed-by: Markus Klein <>
Tested-by: TYPO3com <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Richard Haeser <>
Tested-by: Richard Haeser <>
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>

Revision c3e9b275 (diff)
Added by Georg Ringer almost 2 years ago

[BUGFIX] Make it possible to add cHash to preview links

It must be possible to generate preview URLs with a cHash, e.g. to
display records using Extbase which enforces cHash usage.

Introduce a new option "useCacheHash" which triggers cHash calculation.
If not specified, the "no_cache" parameter is added just like before.

Resolves: #78336
Resolves: #81297
Releases: master, 8.7
Change-Id: I225e2b8b4355022e7b4f6866c989b707e526e389
Reviewed-on: https://review.typo3.org/55255
Reviewed-by: Richard Haeser <>
Tested-by: Richard Haeser <>
Tested-by: TYPO3com <>
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#2 Updated by Josef Glatz about 3 years ago

  • Description updated (diff)

#3 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#4 Updated by Josef Glatz about 3 years ago

  • Description updated (diff)

#5 Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#6 Updated by Gerrit Code Review about 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#7 Updated by Gerrit Code Review about 3 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#8 Updated by Gerrit Code Review almost 3 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#9 Updated by Gerrit Code Review over 2 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#10 Updated by Mathias Brodala over 2 years ago

  • Related to Bug #81297: Extbase record preview leads to 404 due to missing cHash added

#11 Updated by Gerrit Code Review over 2 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#12 Updated by Gerrit Code Review over 2 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#13 Updated by Georg Ringer over 2 years ago

  • Duplicated by Bug #81417: Record preview leads to error &cHash empty added

#14 Updated by Gerrit Code Review over 2 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#15 Updated by Gerrit Code Review over 2 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#16 Updated by Gerrit Code Review about 2 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#17 Updated by Gerrit Code Review almost 2 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#18 Updated by Gerrit Code Review almost 2 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#19 Updated by Gerrit Code Review almost 2 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#20 Updated by Gerrit Code Review almost 2 years ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#21 Updated by Gerrit Code Review almost 2 years ago

Patch set 18 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#22 Updated by Gerrit Code Review almost 2 years ago

Patch set 19 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#23 Updated by Gerrit Code Review almost 2 years ago

Patch set 20 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50264

#24 Updated by Georg Ringer almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#25 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55255

#26 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55255

#27 Updated by Georg Ringer almost 2 years ago

  • Status changed from Under Review to Resolved

#28 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF