Bug #79043

PSR-7 non 302 redirects do not work

Added by Benjamin Franzke over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-12-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If a Response object sets a status code other than 302 and adds a Location header,
Core\Bootstrap::sendResponse will always sent a 302 response code, instead of the defined one.

This is because the php header() function implicitly sets the response code to 302 if a location header is sent:
http://php.net/manual/en/function.header.php#refsect1-function.header-parameters

#1

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51002

#2

Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51815

#3

Updated by Benjamin Franzke over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF