Bug #79091

Click menu: Delete page in click menu doesn't works

Added by Gianluigi Martino over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-12-24
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Delete option in click menu doesn't works.

Chrome console say: Uncaught SyntaxError: Unexpected

Bug in master and 7.6 but not same code.


Related issues

Related to TYPO3 Core - Task #72617: Use new confirmation dialog for ClickMenu Closed 2016-01-09

Associated revisions

Revision f5a07ab7 (diff)
Added by Tymoteusz Motylewski about 3 years ago

[BUGFIX] Fix JS errors in context menu

Fixes two issues: syntax error (missing semicolon),
and "Uncaught TypeError: Cannot read property 'refresh' of undefined"
when e.g. deleting a page or a file.

In file module, refresh is not needed as all actions are refreshing
the frames anyway.

Releases: master, 7.6
Resolves: #79091
Change-Id: Icfc9f786c24099c55d8e60cf30f72f035ae28231
Reviewed-on: https://review.typo3.org/51251
Reviewed-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Tested-by: Wouter Wolters <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 1e85fe49 (diff)
Added by Tymoteusz Motylewski about 3 years ago

[BUGFIX] Fix JS errors in context menu

Fixes two issues: syntax error (missing semicolon),
and "Uncaught TypeError: Cannot read property 'refresh' of undefined"
when e.g. deleting a page or a file.

In file module, refresh is not needed as all actions are refreshing
the frames anyway.

Releases: master, 7.6
Resolves: #79091
Change-Id: Icfc9f786c24099c55d8e60cf30f72f035ae28231
Reviewed-on: https://review.typo3.org/51262
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Tymoteusz Motylewski about 3 years ago

this seems to be a regression introduced with https://review.typo3.org/#/c/47054

#2 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51251

#3 Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51251

#4 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51251

#5 Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51262

#6 Updated by Tymoteusz Motylewski about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Gerrit Code Review about 3 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51262

#8 Updated by Tymoteusz Motylewski about 3 years ago

  • Status changed from Under Review to Resolved

#9 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF