Bug #79116

Delete-infinite-loop: fileadmin/_recycler_ preview images

Added by Clemens Riccabona over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2016-12-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you use fileadmin/_recycler feature and you have activated 'Preview Images', you will experience some nice infinte delete-loop when trying to clean recycler manually.

Reproduction:
1. activate recycler-feature by creating according folder (fileadmin/_recycler_/)
2. activate the display of preview-images in backend
3. go to file-list fileadmin/_recycler_/ and delete some files from there manually.

you will see preview_ prefixed files, and preview_preview_ prefixed, and preview_preview_preview_ prefixed .... and so on.


Related issues

Related to TYPO3 Core - Bug #79804: Task for clearing _recycler_ failsClosed2017-02-14

Actions
Has duplicate TYPO3 Core - Bug #81836: deleting a file inside _recycler_ folder generates new file with preview_ prefixClosed2017-07-11

Actions
#1

Updated by Riccardo De Contardi about 4 years ago

still a problem in latest master

#2

Updated by Guido S. over 3 years ago

  • Has duplicate Bug #81836: deleting a file inside _recycler_ folder generates new file with preview_ prefix added
#3

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Closed

Thank you, Guido S. for your findings :)

I close this issue as a duplicate of #81836 , please continue the discussion there, there is a patch under review; thank you.
A reference has been added to this issue to keep track of it

If you think that this is the wrong decision, then please reopen it or open a new ticket and add a relation to this ticket number.

Thank you and best regards.

Also available in: Atom PDF