Bug #79314

Outdated PHPDoc comment in AbstractTreeView

Added by Stefan Rotsch over 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2017-01-13
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

While making an old extension work in TYPO3 7.6 and 8, I found that behavior of the AbstractTreeView has changed between 7.6.

The description of the variable $makeHTML is outdated, as it describes a configuration option no longer existing:

    /**
     * If TRUE, HTML code is also accumulated in ->tree array during rendering of the tree.
     * If 2, then also the icon prefix code (depthData) is stored
     *
     * @var int
     */
    public $makeHTML = 1;

The variable is treated as a boolean since 7.6, the mentioned value of "2" does not have any effect, so the affected line should be removed.

Ideally, the variable should be converted to a boolean. But as it's a public variable, I assume this would be considered a breaking change, so please let me know if I should provide a patch set for that, too.

Associated revisions

Revision 1c09924f (diff)
Added by Stefan Rotsch over 2 years ago

[BUGFIX] Remove outdated PHPDoc comment

The described behavior has been removed with TYPO3 7.6;
the variable is treated as a boolean now.

Resolves: #79314
Releases: master
Change-Id: I456ad1884a9a40c22c2015d19aa5abdd623a1654
Reviewed-on: https://review.typo3.org/51308
Reviewed-by: Mathias Brodala <>
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51308

#2 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51308

#3 Updated by Stefan Rotsch over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF