Feature #79440

FormEngine element level refactoring

Added by Christian Kuhn about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2017-01-24
Due date:
% Done:

100%

PHP Version:
Tags:
Complexity:
hard
Sprint Focus:

Related issues

Related to TYPO3 Core - Bug #69295: Suggest wizard is too small and looks wrong, when located at right side of type='group' Closed 2015-08-24
Related to TYPO3 Core - Bug #79576: master: Password fields in Backend show data (not marked as type="password") Closed 2017-02-01
Related to TYPO3 Core - Bug #79632: Null placeholder initialization in inline expand Closed 2017-02-05
Related to TYPO3 Core - Bug #79574: Suggest wizard in flexform broken Closed 2017-01-31
Related to TYPO3 Core - Bug #79714: Saving a backend user record without touching the password field, sets the password to '*********' Closed 2017-02-09
Related to TYPO3 Core - Bug #79508: SelectIcon rendering does not fit in screen Closed 2017-01-26
Precedes TYPO3 Core - Bug #85729: Exception "htmlspecialchars() expects parameter 1 to be string, integer given" in TCA, if label column consists of an int Closed 2017-01-25 2017-01-25

Associated revisions

Revision 84be5e61 (diff)
Added by Christian Kuhn almost 3 years ago

[!!!][FEATURE] FormEngine element level refactoring

The patch introduces a new API on FormEngine element level
that substitutes the old "wizards" / renderWizard() API
with a more powerful system.

Single wizards are now split into one of three categories:
  • An informational wizard
  • A control button / icon
  • A true wizard with additonal functionality

Method renderWizards() is still called in elements for compatibility
reasons if people added own scrip/popup/userFunc wizards, but all
core wizards are migrated.

The patch significantly cleans the HTML of single elements, especially
HTML stuff that was added by the SingleFieldContainer is now put down
to single elements, while main HTML wraps formerly done by renderWizards()
is fetched "up" to single elements. This gives single elements full
control about the main HTML it is producing, which is a must have
preparation in order to further advance in this area and to switch
single elements to fluid rendering in one of the next steps.

The patch brings a pretty huge list of TCA changes and
simplifications, all TCA changes are supported by TCA migration,
so existing extensions should benefit out of the box and just
get deprecations logged.

Change-Id: I45083e14e45bbf40c06267b51c9d0b7c15e2f7ab
Resolves: #79440
Resolves: #70032
Releases: master
Reviewed-on: https://review.typo3.org/51151
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Mona Muzaffar <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 3781ab49 (diff)
Added by Christian Kuhn almost 3 years ago

[BUGFIX] Suggest wizard in flex forms

A broken variable access is fixed to hand over correct data
to the type=group suggest wizard.

Change-Id: I0c6dbf3d7da114f633e779eb594b6457a5e4fac6
Resolves: #79574
Related: #79440
Releases: master
Reviewed-on: https://review.typo3.org/51543
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision fd1be0ca (diff)
Added by Christian Kuhn almost 3 years ago

[BUGFIX] Null placeholder initialization in inline expand

Opening a collapsed inline relation containing null placeholders
does not correctly initialize and both the value field as well as
the placeholder field are shown.
Easily reproducible with a FAL relation on a page record.
Fix JavaScript to initialize correctly.

Change-Id: I27b52b9f69beb24d0309422cbcf2b67cc8190e07
Resolves: #79632
Related: #79440
Releases: master
Reviewed-on: https://review.typo3.org/51542
Tested-by: TYPO3com <>
Reviewed-by: Alex Kellner <>
Tested-by: Alex Kellner <>
Reviewed-by: Bjoern Jacob <>
Tested-by: Bjoern Jacob <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 98000585 (diff)
Added by Frank Naegler over 1 year ago

[BUGFIX] Fix override handling for element specific field values

This patch fixes a broken JavaScript code which removes the field and
placeholder divs in FormeEngine.js field override handling.

Resolves: #84689
Related: #79440
Related: #70032
Releases: master, 8.7
Change-Id: I91d40b6ff7baa9fa9ea121458a7a9faaa00ec6f9
Reviewed-on: https://review.typo3.org/57348
Reviewed-by: Wouter Wolters <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 3686e566 (diff)
Added by Frank Naegler over 1 year ago

[BUGFIX] Fix override handling for element specific field values

This patch fixes a broken JavaScript code which removes the field and
placeholder divs in FormeEngine.js field override handling.

Resolves: #84689
Related: #79440
Related: #70032
Releases: master, 8.7
Change-Id: I91d40b6ff7baa9fa9ea121458a7a9faaa00ec6f9
Reviewed-on: https://review.typo3.org/57377
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>
Tested-by: TYPO3com <>

Revision 8db8e07c (diff)
Added by Stephan Großberndt over 1 year ago

[BUGFIX] Avoid exception for int label column

By casting the title column to string for the label of an TCA record an
exception caused by a strict type check is avoided when shortening the
title.

Resolves: #85729
Related: #79440
Releases: master, 8.7
Change-Id: Ie365b92ae73cd766c412d66ff7624eebbbfb3cf7
Reviewed-on: https://review.typo3.org/57776
Reviewed-by: Riny van Tiggelen <>
Reviewed-by: Jan Stockfisch <>
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

Revision 3dc41160 (diff)
Added by Stephan Großberndt over 1 year ago

[BUGFIX] Avoid exception for int label column

By casting the title column to string for the label of an TCA record an
exception caused by a strict type check is avoided when shortening the
title.

Resolves: #85729
Related: #79440
Releases: master, 8.7
Change-Id: Ie365b92ae73cd766c412d66ff7624eebbbfb3cf7
Reviewed-on: https://review.typo3.org/57780
Tested-by: TYPO3com <>
Reviewed-by: Stephan Großberndt <>
Tested-by: Stephan Großberndt <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 67 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51151

#2 Updated by Gerrit Code Review about 3 years ago

Patch set 68 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51151

#3 Updated by Gerrit Code Review about 3 years ago

Patch set 69 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51151

#4 Updated by Gerrit Code Review about 3 years ago

Patch set 70 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51151

#5 Updated by Gerrit Code Review about 3 years ago

Patch set 71 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51151

#6 Updated by Gerrit Code Review almost 3 years ago

Patch set 72 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51151

#7 Updated by Gerrit Code Review almost 3 years ago

Patch set 73 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51151

#8 Updated by Christian Kuhn almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

#10 Updated by Stephan Großberndt over 1 year ago

  • Precedes Bug #85729: Exception "htmlspecialchars() expects parameter 1 to be string, integer given" in TCA, if label column consists of an int added

Also available in: Atom PDF