Bug #79831

Content Rendering not working after upgrade 8.5.1 > 8.6.0

Added by Carsten Hülsmann over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2017-02-15
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

it seems there is a problem with the content rendering.
Since the upgrade my cObjects stay empty...

Tried much but can't recognize why.


page.10 = FLUIDTEMPLATE
page.10 {
format = html
partialRootPath = {$resDir}/Private/Partials/
layoutRootPath = {$resDir}/Private/Layouts/
variables {
content0 < styles.content.get
content0.select.where = colPos = 0
content1 < styles.content.get
content1.select.where = colPos = 1
content2 < styles.content.get
content2.select.where = colPos = 2
content3 < styles.content.get
content3.select.where = colPos = 3
hintergrundfarbe = TEXT
hintergrundfarbe.insertData = 1
hintergrundfarbe.data = page : tx_pk_netfactory_bgcolor
textflow = TEXT
textflow.insertData = 1
textflow.data = tt_content : tx_pk_netfactory_textflow
}
}
page.10.file.stdWrap.cObject = CASE
page.10.file.stdWrap.cObject {
key.data = levelfield:-1, backend_layout_next_level, slide
key.override.field = backend_layout
default = TEXT
default.value = {$resDir}/Private/Templates/onepage.html
pagets__1 < default
}

No relevant error in logs. If i do it directly page.10 < styles.content.get everything is fine.

Any suggestions where to look?

page.ts (1.05 KB) Carsten Hülsmann, 2017-02-15 15:49

8-6-0-Template-Hierarchie.png View - Template-Hierarchy (16.8 KB) Wittkiel Gruppe, 2017-02-16 09:27


Related issues

Related to TYPO3 Core - Bug #80044: styles.content.get not available in FSC anymore Closed 2017-02-27

History

#1 Updated by Wittkiel Gruppe over 2 years ago

We had similar problems after update 8.5.1 > 8.6.0:
With 8.6.0 it seems they removed "typo3/sysext/fluid_styled_content/Configuration/TypoScript/Static/Setup/styles.content.get.ts" in #79622

styles.content.get = CONTENT
styles.content.get {
    table = tt_content
    select.orderBy = sorting
    select.where = colPos=0
}

before 8.6:
lib.pageContent < styles.content.get
lib.pageContent.select.where = colPos = 0
now with 8.6:
lib.pageContent = CONTENT
lib.pageContent.table = tt_content
lib.pageContent.select {
orderBy = sorting
where = colPos = 0
}

#2 Updated by Carsten Hülsmann over 2 years ago

Wittkiel Gruppe wrote:

We had similar problems after update 8.5.1 > 8.6.0:
With 8.6.0 it seems they removed "typo3/sysext/fluid_styled_content/Configuration/TypoScript/Static/Setup/styles.content.get.ts" in #79622
[...]
before 8.6:
lib.pageContent < styles.content.get
lib.pageContent.select.where = colPos = 0
now with 8.6:
lib.pageContent = CONTENT
lib.pageContent.table = tt_content
lib.pageContent.select {
orderBy = sorting
where = colPos = 0
}

Ok but the styles.content.get.ts is now available via the sysext "frontend" (see ext_typoscript_setup.txt within sysext > frontend directory).
So i think the TS should work properly?

#3 Updated by Wittkiel Gruppe over 2 years ago

Carsten Hülsmann wrote:

Ok but the styles.content.get.ts is now available via the sysext "frontend" (see ext_typoscript_setup.txt within sysext > frontend directory).
So i think the TS should work properly?

Hmm, you're right.
We're using a custom-distribution-extension ("wkgsource") with outsourced files (setup.txt, constants.txt..). Perhaps the order of loading could be the problem (see attached file)?! In 8.5 it was defined in fluid_styled_content (before custom-ext.), now with 8.6 in frontend (after custom-ext.).

#4 Updated by Axel Didszun over 2 years ago

Hi,

we had exactly the same issue. We had to do two things to solve the problem:
Change your TS from

page.10 = FLUIDTEMPLATE
page.10 {
format = html
partialRootPath = {$resDir}/Private/Partials/
layoutRootPath = {$resDir}/Private/Layouts/

to (.10)
page.10 = FLUIDTEMPLATE
page.10 {
format = html
partialRootPath.10 = {$resDir}/Private/Partials/
layoutRootPath.10 = {$resDir}/Private/Layouts/

In our case we have a layout which renders specific section in a template. we had wrote the section in lowercase. If your wrote the first letter uppercase then it works.
In Layout

<f:render section="main" /> to <f:render section="Main" />

In Template
<f:section name="main"> to <f:section name="Main">

Can you try this?

Best regards
Axel

#5 Updated by Mona Muzaffar over 2 years ago

  • Status changed from New to Needs Feedback

#6 Updated by Andre Koller over 2 years ago

Doesn´t work for me.
I got the same template-hierarchy as Wittkiel Gruppe with a custom distribution.

#7 Updated by Wittkiel Gruppe over 2 years ago

Wittkiel Gruppe wrote:

We're using a custom-distribution-extension ("wkgsource") with outsourced files (setup.txt, constants.txt..). Perhaps the order of loading could be the problem (see attached file)?! In 8.5 it was defined in fluid_styled_content (before custom-ext.), now with 8.6 in frontend (after custom-ext.).

It's working again for us with 8.7.0 (see fix #80044).

#8 Updated by Mona Muzaffar over 2 years ago

  • Status changed from Needs Feedback to Resolved

i am closing this ticket since this issue seems to be resolved (see related ticket).
Please reopen this ticket, if you are still experiencing this issue in 8.7.

#9 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF