Project

General

Profile

Actions

Bug #79835

closed

UriBuilder for BE modules must not throw away empty parameters

Added by Markus Klein about 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend API
Target version:
Start date:
2017-02-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

\TYPO3\CMS\Backend\Routing\UriBuilder::buildUri() calls GeneralUtility::implodeArrayForUrl with the parameter to skip empty parameters.
This is a wrong behaviour, since empty arguments can be on purpose and it is up to the developer to care about those.

Actions

Also available in: Atom PDF