Bug #80101

Extbase getContentObject() gets no result by calling in another controller

Added by Mathias no-lastname-given over 3 years ago. Updated 8 months ago.

Status:
Needs Feedback
Priority:
Should have
Assignee:
-
Category:
Extbase
Start date:
2017-03-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Following situation:
  • extbase extension with controller classes
  • flexform with "calling cascade" -> in switchableControllerActions in the itemField are the following settings:
    <items type="array">
      <numIndex index="0" type="array">
        <numIndex index="0">Label of Form in Backend</numIndex>
        <numIndex index="1">ControllerA->show;ControllerB->edit</numIndex>
      </numIndex>
    </items>
    
  • in my example ControllerB has a detail view of an table entry and is calling by a link of ControllerA (a new user call)
  • both controller inherit from ActionController

When I call the following lines, ControllerA gets a result set of pid and uid. But ControllerB gets an empty set.

$cObj = $this->configurationManager->getContentObject();
$resultset = array("uid" => $cObj->data['uid'], "pid" => $cObj->data['pid']);

Is this behavior intended or is it a bug? Does exists a workaround?

Typo3-Version: 7.6.16


Related issues

Related to TYPO3 Core - Epic #88528: Remove switchable controller action functionalityIn Progress2019-06-08

Actions
#1

Updated by Benni Mack over 1 year ago

  • Target version changed from next-patchlevel to Candidate for patchlevel
#2

Updated by Christian Eßl 9 months ago

  • Related to Epic #88528: Remove switchable controller action functionality added
#3

Updated by Stefan Froemken 8 months ago

  • Status changed from New to Needs Feedback

Hello Mathias,

can you please test, if this issue is still valid for TYPO3 9 or 10?

Stefan

Also available in: Atom PDF