Task #80149

Remove $GLOBALS['TYPO3_CONF_VARS']['FE']['pageOverlayFields']

Added by Oliver Hader over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2017-03-06
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Sprint Focus:

Description

The configuration $GLOBALS['TYPO3_CONF_VARS']['FE']['pageOverlayFields']
is removed from the default configuration as well as from the overlay
handling in PageRepository and RootlineUtility. This setting has been
used to determine overlay fields in the table pages_language_overlay at
a time in the runtime processing when the complete TCA was not fully
available. Since the allowLanguageSynchronization possibility has been
integrated into TYPO3 CMS 8, l10n_mode was available already and the TCA
is loaded as well, the pageOverlayFields settings are superfluous.


Related issues

Related to TYPO3 Core - Feature #83863: Add language property for references of FILES cObject / levelmedia New 2018-02-12

Associated revisions

Revision bce9a838 (diff)
Added by Oliver Hader over 2 years ago

[!!!][TASK] Remove $TYPO3_CONF_VARS['FE']['pageOverlayFields']

The configuration $GLOBALS['TYPO3_CONF_VARS']['FE']['pageOverlayFields']
is removed from the default configuration as well as from the overlay
handling in PageRepository and RootlineUtility. This setting has been
used to determine overlay fields in the table pages_language_overlay at
a time in the runtime processing when the complete TCA was not fully
available. Since the allowLanguageSynchronization possibility has been
integrated into TYPO3 CMS 8, l10n_mode was available already and the TCA
is loaded as well, the pageOverlayFields settings are superfluous.

Change-Id: I36198d7dec94204fc761048de705aa03a5e931c3
Resolves: #80149
Releases: master
Reviewed-on: https://review.typo3.org/51954
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51954

#2 Updated by Oliver Hader over 2 years ago

  • Description updated (diff)

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51954

#4 Updated by Oliver Hader over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Joe Jones about 2 years ago

  • Priority changed from Should have to Must have

Hallo Oliver,

thank you for your Work. This issue makes me helpless. I want the page media fallback to the standard language. Once it was possible with adding the field to pageOverlayFields, but since 8.7 this Configuration is removed. In the Changelog you have a hint to the Migration, but I do not get it. In the documentation there also is no point about this.

    headerimage = FILES
    headerimage {
        references {
            table = pages
            data = levelmedia: -1, slide
            fieldName = media
        }
        begin = 0
        maxItems = 1
        renderObj = TEXT
        renderObj {
            data = file:current:publicUrl
            wrap = background-image:url(|);
        }
    }

What has to be change, that TYPO3 takes the page.media from the standard language, if there is no page.media in the L1-version. This should consider the sliding as well.

Thanks and sorry for asking a maybe stupid question this way.
Martin

#6 Updated by Ben Robinson almost 2 years ago

The problem ist that references of FILES does not allow a languageField query.

Here's a workaround, but without any "slide":

headerimage = CONTENT
headerimage{
    table = sys_file_reference
    select{
        pidInList = this
        where = tablenames='pages' AND fieldname='media'
        orderBy = sorting_foreign
        languageField = 0
        selectFields = uid_local
    }
    renderObj = FILES
    renderObj{
        files.stdWrap.field = uid_local
        renderObj = IMG_RESOURCE
        renderObj{
            file.import.data = file:current:publicUrl
            stdWrap.wrap = background-image:url(|);
        }
    }
}

#7 Updated by Ben Robinson over 1 year ago

  • Related to Feature #83863: Add language property for references of FILES cObject / levelmedia added

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF