Project

General

Profile

Actions

Bug #80343

closed

EXT:form - HTML double-encoding of form name in "form tree" (BE)

Added by Martin Kutschker over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2017-03-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The form name may contain "greater/less than" characters, but unlike page and field names the rendering is broken in the "form tree" (see attached screenshot).


Files

double-encoding.png (50.9 KB) double-encoding.png Martin Kutschker, 2017-03-19 11:48
double-encoding-after-save.png (58.2 KB) double-encoding-after-save.png Martin Kutschker, 2017-03-19 11:54

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #79608: Wrong handling with html tags in EXT:formClosed2017-02-03

Actions
Actions #1

Updated by Martin Kutschker over 7 years ago

After saving the form the < character has disappeared from the form name. Both characters have disappeared from the page name. The only name untouched and handled correctly seems to be the field name (which BTW is rendered correctly in the FE).

This is unexpected. IMHO there should be no constraints on the names. I think this is what is meant in #79608.

Actions #2

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52094

Actions #3

Updated by Ralf Zimmermann over 7 years ago

  • Category set to Form Framework
Actions #4

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52094

Actions #5

Updated by Anonymous about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF