Bug #80723

8.7 LTS Upgrade Wizard: Execute database migrations on single rows failed

Added by Patrick no-lastname-given almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2017-04-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In v8 LTS Upgrade Wizard on step "Execute database migrations on single rows" i get an Uncaught TYPO3 Exception.

NAMEPREP: Prohibited input U+0000003D 
InvalidArgumentException thrown in file
xxxx\vendor\mso\idna-convert\src\Punycode.php in line 335.

I think the step "Scan for old "<link>" syntax in richtext and text fields and update to "<a href>"" has a bug with links like this:

<link email@mail.mail?subject=Anfrage:%20Text%20Text%20Lösungen>Mehr erfahren</link>

Screenshot file in attachment.


Files

TYPO3_v8_LTS_Upgrade-Wizard-Bug.pdf (342 KB) TYPO3_v8_LTS_Upgrade-Wizard-Bug.pdf Patrick no-lastname-given, 2017-04-06 11:12

Related issues

Related to TYPO3 Core - Bug #80712: Handle errors in row updatersClosedMarkus Klein2017-04-05

Actions
Related to TYPO3 Core - Bug #81211: Uncought Exeption in list-modul (NAMEPREP: Prohibited input U+0000003E)Rejected2017-05-12

Actions
#1

Updated by Thomas Hohn almost 4 years ago

Seems like a copy of 80712

#2

Updated by Morton Jonuschat almost 4 years ago

No, this seems to be a bug due to the whole link destionation being passed to punycode. I suspect that the ?subject part trips it up.

#3

Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52402

#4

Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52402

#5

Updated by Morton Jonuschat almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Joe Jones over 3 years ago

  • Related to Bug #81211: Uncought Exeption in list-modul (NAMEPREP: Prohibited input U+0000003E) added
#7

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF