Bug #81211

Uncought Exeption in list-modul (NAMEPREP: Prohibited input U+0000003E)

Added by Joe Jones over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2017-05-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Dear TYPO3 Team,

I updated a TYPO3 Installation. The Install Tool was fine (not as told in Bug #80723), but the same exeption is thown in the list modul. In the module web it is no problem.

Not alle pages with email adresses make problems. Maybe it is not even an upgrade problem.

1. Adding a new contentelement Image/Text.
2. Adding text with the ckeditor. Just a few simple lines with ü, ä, ö
3. Save and open list modul
--> No problem
4. Open the CE and adding a line with an email adress at the end
5. Save and open list modul
--> No problem
6. Open the CE and adding some english text
7. Save and open list modul
--> No problem
8. Open the CE and adding some Text with ö, ü, ä
9. Save and open list modul
--> the list modul crashes

Following pattern makes problems:
- string@string followed by any umlaut

Following patterns make no problems
- string ummlaut
- string string umlaut sting
- string space space string umlaut
- string space @string umlaut
- string
space string umlaut
- <LINK >string space @ space string</LINK> umlaut (setting link with link editor)

It seams, that the conventional pattern of an email address as link text breaks the link validator, if an special char (umlaut) follows -- strange correlation :-/

Please check this and ask, if you need additional informationen.

Thank you
Martin


Files

NAMEPREP.html (42.4 KB) NAMEPREP.html Joe Jones, 2017-05-12 15:27

Related issues

Related to TYPO3 Core - Bug #80723: 8.7 LTS Upgrade Wizard: Execute database migrations on single rows failedClosed2017-04-06

Actions
Is duplicate of TYPO3 Core - Bug #80969: List module: Content elments with additional column pi_flexform results in exception "Prohibited input U+0000000A"Closed2017-04-23

Actions
#1

Updated by Joe Jones over 3 years ago

  • Related to Bug #80723: 8.7 LTS Upgrade Wizard: Execute database migrations on single rows failed added
#2

Updated by Wouter Wolters over 3 years ago

  • Status changed from New to Rejected

Hi thanks for the report but there is already an existing report with a possible solution available.
I'll close this ticket as duplicate of https://forge.typo3.org/issues/80969

#3

Updated by Wouter Wolters over 3 years ago

  • Is duplicate of Bug #80969: List module: Content elments with additional column pi_flexform results in exception "Prohibited input U+0000000A" added

Also available in: Atom PDF