Project

General

Profile

Actions

Bug #80839

closed

RTE CKEditor

Added by Tommy Bley almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend JavaScript
Target version:
Start date:
2017-04-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
BE Js, CKEditor, Flexforms, Own Extension
Complexity:
easy
Is Regression:
Sprint Focus:

Description

i used the CKEditor (Be) for my own Extension, with Flexforms. And make dots in me setting arguments e.g.

<settings.description>
<TCEforms>
<exclude>1</exclude>
<label>Beschreibung</label>
<config>
<type>text</type>
<rows>5</rows>
<cols>30</cols>
<eval>trim</eval>
</config>
<defaultExtras>richtext[]:rte_transform[mode=ts_css]</defaultExtras>
</TCEforms>
</settings.description>

then i got the following error Message

index.php?route=%2Frecord%2Fedit&token=d0ec8fb…&edit[tt_content][39…:245 Uncaught TypeError: Cannot read property 'description' of undefined at index.php?route=%2Frecord%2Fedit&token=d0ec8fb…&edit[tt_content][39…:245
...

The problem is:

require(["ckeditor"], function(CKEDITOR) {

...
require(['TYPO3/CMS/Backend/FormEngine'], function(FormEngine) {
CKEDITOR.instances.data_tt_content__39__pi_flexform__data__general__lDEF__settings.description__vDEF_.on('change', function() {
CKEDITOR.instances.data_tt_content__39__pi_flexform__data__general__lDEF__settings.description__vDEF_.updateElement();
FormEngine.Validation.validate();
});
});
});

the CKEDITOR Object make the eventhandling to onChange with the requlare dots, but with spaceing dots in my variable broke the settings.

From:
CKEDITOR.instances.data_tt_content__39__pi_flexform__data__general__lDEF__settings.description__vDEF_.on('change'

Must change to:
CKEDITOR.instances['data_tt_content__39__pi_flexform__data__general__lDEF__settings.description__vDEF_'].on('change'

Thx :)

Actions #1

Updated by Filipe DA COSTA COSTA almost 7 years ago

I'm having the same issue.

Tommy's proposed changes seems to work.

Actions #2

Updated by Benni Mack almost 7 years ago

  • Target version changed from 8 LTS to next-patchlevel
Actions #3

Updated by Łukasz Uznański over 6 years ago

It's already solved here: https://review.typo3.org/#/c/53490/

Actions #4

Updated by Frank Nägler over 6 years ago

  • Status changed from New to Closed

I will close this issue, because it is already fixed in v8 and master with: https://review.typo3.org/#/c/53490/
If I am wrong, please feel free to open a new issue.

Actions

Also available in: Atom PDF