Bug #80975

Indexed Search form is not cacheable

Added by Christian Toffolo over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Indexed Search
Target version:
Start date:
2017-04-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Indexed Search registers the plugin with the 'form' action has not cacheable:

// register extbase plugin
\TYPO3\CMS\Extbase\Utility\ExtensionUtility::configurePlugin('TYPO3.CMS.IndexedSearch', 'Pi2', ['Search' => 'form,search,noTypoScript'], ['Search' => 'form,search']);

If there's not a particular reason, I suggest to remove 'form' action from the not cachable.

Use case: there's a small search form in every page of a website. The searches made with this form are redirected to the search page.
Since the form, even if set as USER, is converted ad USER_INT because 'form' action is not cacheable, extensions like nc_staticfilecache don't cache the pages statically because of the USER_INT.

#1

Updated by Christian Toffolo over 3 years ago

  • Assignee set to Christian Toffolo
#2

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52564

#3

Updated by Benni Mack over 3 years ago

  • Target version changed from 8 LTS to next-patchlevel
#4

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52564

#5

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52564

#6

Updated by Susanne Moog over 1 year ago

  • Status changed from Under Review to Closed

Patch has been abandoned and issue solution documented in review comments.

Also available in: Atom PDF