Bug #80986

LinkService does not recognize old RTE links with id= format

Added by Markus Klein over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2017-04-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Hence the link upgrader fails during 8.7 upgrade.

#1320286857: File ../?id=618 is not valid (".." and "//" is not allowed in path). 

example link:

<link ../?id=618 - internal-link "Opens internal link in current window"><img src="fileadmin/_migrated/RTE/RTEmagicC_5948ab6911.gif.gif" data-htmlarea-file-uid="425" data-htmlarea-file-table="sys_file" height="10" width="14" alt="" />Termine</link>
#1

Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52567

#2

Updated by Markus Klein over 4 years ago

  • Description updated (diff)
  • Status changed from Under Review to Accepted
#3

Updated by Markus Klein over 4 years ago

  • Status changed from Accepted to Under Review
#4

Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52567

#5

Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52618

#6

Updated by Markus Klein over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52666

#8

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52666

#9

Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52666

#10

Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52673

#11

Updated by Christer V over 4 years ago

  • Status changed from Under Review to Resolved
#12

Updated by Christian Stern over 4 years ago

Markus Klein wrote:

Hence the link upgrader fails during 8.7 upgrade.

[...]

example link:

[...]

Will this also deal with direct links to files? I just run into this issue caused by links like this: ../fileadmin/x/y/file.txt

A small workaround that helped me was to update those links directly via sql. I assume no liability for the fact that it works.

UPDATE tt_content
SET bodytext = REPLACE
WHERE bodytext LIKE ('%<link ../?id=%')

UPDATE tt_content
SET bodytext = REPLACE
WHERE bodytext LIKE ('%<link ../%')

#13

Updated by Markus Klein over 4 years ago

No, this is just for page links and not for such direct file links.

If you experience problems with those, please create a dedicated ticket and also explain, how those links might have found their way into the DB. Eg. additional extensions and so on.

#14

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF