Project

General

Profile

Actions

Bug #81003

closed

Setting a different format on the standalone view does not work

Added by Markus Klein almost 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Fluid
Target version:
Start date:
2017-04-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

Rendering the view again after changing the format, does not use the correct templates, because the format is not adhered.

Testing instructions:

- Create StandaloneView in a controller
- Create 2 Fluid templates (.html and .txt) with different markup/content
- Render the view once
- change the format to 'txt' and render again
- Check if the output of each render call is correct.

(without a fix the output is always the html content)

Actions #1

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52594

Actions #2

Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52594

Actions #3

Updated by Markus Klein almost 7 years ago

  • Description updated (diff)
Actions #4

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52616

Actions #5

Updated by Markus Klein almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF