Bug #81587

Questionable behaviour of l10n_mode "exclude" in list module

Added by Christian Richter 12 months ago. Updated 24 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2017-06-15
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
l10n, translation
Complexity:
Is Regression:
Sprint Focus:

Description

I'm currently in the process of upgrading a TYPO3 7.6.16 instance to 8.7.1.
If I configure a field as

return [
    'ctrl' => [

        [...]

        'label' => 'subject',

        [...]

'subject' => [
    'exclude' => 0,
    'l10n_mode' => 'exclude',
    'label' => 'LLL:EXT:calendar/Resources/Private/Language/locallang_db.xlf:tx_calendar_domain_model_event.subject',
    'config' => [
        'type' => 'input',
        'size' => 30,
        'eval' => 'trim'
    ,
],

I have to import the default languages subject in both languages during record-creation, for it to be displayed in the list-module, even if I don't want the subject to be editable in the backend.

If the translated records subject is empty in the database, shouldn't the default records label getting displayed for less BE-editor confusion?

Best regards
Christian

l10n_exclude_7_6_16.png View - v7.6.16 the "subject" of the default language is shown (23 KB) Christian Richter, 2017-06-15 15:24

l10n_exclude_8_7_1.png View - v8.7.1the "subject" of the translated record is shown, which is empty (60.2 KB) Christian Richter, 2017-06-15 15:24

History

#1 Updated by Oliver Hader 11 months ago

  • Status changed from New to Needs Feedback

This issue has been tagged with "IRRE". Can you please provide the full TCA configuration and describe how this is related in inline-relational-record-editing context? Thx

#2 Updated by Christian Richter 11 months ago

  • Tags changed from l10n, irre, translation to l10n, translation

I'm sorry, this issue is not related to IRRE at all.
That was a mistake!

#3 Updated by Alexander Opitz 7 months ago

Hi,

does this issue happens with latest TYPO3 8 LTS? (8.7.8)

#4 Updated by Mathias Schreiber 5 months ago

  • Is Regression deleted (Yes)

Can you explain what you mean by "import records"?

The main issue here is that TYPO3s DataHandler will copy the values over from default to translated.
So if you create a translated record in the DB yourself, you need to get the value from its language parent yourself and add said value to the respective field.

#5 Updated by Mathias Schreiber 5 months ago

  • Assignee set to Mathias Schreiber

#6 Updated by Oliver Hader 5 months ago

On using l10n_mode=exclude the values in localized records are only updated if the language default record (l10n_parent record) is updated.

I guess in this case the localized record is directly imported (without using the "localize" command in DataHandler). In this case, the accordings field "subject" is sanitized since it cannot be modified in localizations directly but is triggered when the language default records get updated.

#7 Updated by Alexander Opitz 24 days ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Mathias Schreiber)
  • Target version deleted (next-patchlevel)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF