Bug #81740

temp directory name shouldn't be hardcoded in ClearCacheService

Added by Marco Huber over 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2017-06-29
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

As the name of the temp directory can be configured (f.e.

$GLOBALS['TYPO3_CONF_VARS']['SYS']['caching']['cacheConfigurations']['cache_core']['options']['cacheDirectory'] = 'typo3temp_local';
), the name "typo3temp" shouldn't be hardcoded in the ClearCacheService Line 42 (TYPO3 7.6 Line 56).


Related issues

Related to TYPO3 Core - Feature #69975: Make typo3temp-path configurable Closed 2015-09-19

History

#1 Updated by Marco Huber over 2 years ago

Some more information can be found on https://github.com/TYPO3-Console/typo3_console/issues/522

#2 Updated by Riccardo De Contardi over 1 year ago

#3 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57651

#4 Updated by Markus Klein over 1 year ago

  • Status changed from Under Review to Needs Feedback

As explained in the linked ticket of typo3_console, the two-level approach is to do a best-guess and erase caches based on the known default configuration for the edge case the actual configuration is no loadable. As second level the caches are flushed according to the configuration.

So please explain in more detail, why this does not work for you.

#5 Updated by Riccardo De Contardi 12 months ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF