Bug #81749

f:link.action renders invalid links if pageUid param is omitted

Added by Andreas Fernandez over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2017-06-29
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Due to #81213, the pageUid parameter in f:link.action is now always casted to an int. This leads to unwanted behaviour, as pageUid is 0 in such case, causing to break UriBuilder->uriFor() as the pageUid is checked for null. As null !== 0, the page uid is not determined correctly, causing typolink_URL to render empty strings.

This may be tested with EXT:indexed_search, the "Advanced search" link is broken and always links to the current page.
Side effect: submitting its form and clicking "Advanced search" then, exceptions occur.


Related issues

Related to TYPO3 Core - Task #81213: Deprecate ViewHelper render() argument support Closed 2017-05-12

Associated revisions

Revision 36696a35 (diff)
Added by Andreas Fernandez over 2 years ago

[BUGFIX] Do no force int cast of pageUid in f:link.action

Since #81213, the `pageUid` argument is cast to an int. If that
parameter is omitted, pageUid becomes 0. UriBuilder is able to
determine the page uid by itself, but for this, $pageUid must be
null.

Resolves: #81749
Related: #81213
Releases: master
Change-Id: I030ef28efb1a3fdd14246f84c8ce8c464ba04a4d
Reviewed-on: https://review.typo3.org/53359
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Claus Due <>
Reviewed-by: Joerg Boesche <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 509f8280 (diff)
Added by Ralf Merz over 2 years ago

[BUGFIX] Do no force int cast of pageUid in f:link.page

Since #81213, the `pageUid` argument is cast to an int. If that
parameter is omitted, pageUid becomes 0. UriBuilder is able to
determine the page uid by itself, but for this, $pageUid must be
null.

Resolves: #81881
Related: #81749
Releases: master
Change-Id: Ibc211775d657d59491beeaf8c6d4e0ff55c5e6ee
Reviewed-on: https://review.typo3.org/53520
Tested-by: TYPO3com <>
Reviewed-by: Achim Fritz <>
Tested-by: Achim Fritz <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Andreas Fernandez over 2 years ago

  • Related to Task #81213: Deprecate ViewHelper render() argument support added

#2 Updated by Andreas Fernandez over 2 years ago

  • Description updated (diff)

#3 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53359

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53359

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53359

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53359

#7 Updated by Andreas Fernandez over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF