Bug #81801

ckEditor: Text-Align "Center" not working

Added by Gute Botschafter over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2017-07-05
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If one tries to center-align text in the ckEditor via the center-align-button, it does not work correctly.
Instead of adding the class "text-center" to the applied element, the class "text-left" is added (see appended screenshot).

All other options (text-left, text-right, text-justify) work properly.

screenshot.jpg View - Screenshot (54.8 KB) Gute Botschafter, 2017-07-05 14:14

Screenshot_1.png View (9.71 KB) Angelo Previtali, 2017-07-13 09:27

Screenshot_2.png View (9.29 KB) Angelo Previtali, 2017-07-13 09:27

typo3-rte_ckeditor-wrong-stylesheet-path.png View (105 KB) Ludwig Rafelsberger, 2017-10-03 18:11

typo3-rte_ckeditor-inexistent-stylesheet-path.png View (35.4 KB) Ludwig Rafelsberger, 2017-10-03 18:17

Schermata 2017-10-25 alle 23.59.49.png View (337 KB) Riccardo De Contardi, 2017-10-26 00:02


Related issues

Related to TYPO3 Core - Bug #84000: Justify buttons are not displayed correctly while overriding justify-classes in custom RTE configuration Closed 2018-02-21

History

#1 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from New to Needs Feedback

Sorry, I am not able to reproduce it with both 8.7.3 and latest master. Could you give us more information about your setup? Is it a fresh TYPO3 install or do you use some extensions?

#2 Updated by Angelo Previtali over 2 years ago

I can confirm a similar thing: If you edit a text with the EXT:ckeditor, you will mark a text and add "center" as alignement, the editor will correctly generate text-align=center but the icon still is on the initial alignement=left posision.

We use 8.7.3 with PHP 7.1

#3 Updated by Riccardo De Contardi over 2 years ago

Still not able to reproduce the issue reported by @Angelo Previtali, but I am using PHP 7.0.15. I don't know if it is important.
Is there some javascript error somewhere?

#4 Updated by Ludwig Rafelsberger about 2 years ago

I can reproduce the issue, also getting

<p class="align-center"></p>
in the code view, but no visual clue and the left-align icon still active.

Is there some javascript error somewhere?

I do have a javascript-related error:

The mentioned file does not exist there:

Seems like a wrong path somewhere to me… The failing CSS load is initiated from a minified javascript (Contrib/ckeditor.js - sorry I am not javascript/frontend-fit enough to dig any further…)

#5 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Needs Feedback to New

#6 Updated by Riccardo De Contardi almost 2 years ago

I am using TYPO3 8.7.8 and I am still not able to reproduce the issue;

I also don't have missing files: the content.css file is in the folder rte_ckeditor/Resources/Public/Css/ - see attached file

#7 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

I've tested again with 8.7.9 and I am still not able to reproduce the issue.

#8 Updated by Riccardo De Contardi over 1 year ago

Not reproducible on 9.2.0-dev, too.

#9 Updated by Jan Stockfisch over 1 year ago

I can verify (TYPO3 8.7.10) the described problem from Angelo Previtali. Will open a new issue for that, scince it's different from the original topic and also test it on my TYPO3 v9 instance.

EDIT: The Issue is #84000 (also referenced above) and this also is in current master.

#10 Updated by Jan Stockfisch over 1 year ago

  • Related to Bug #84000: Justify buttons are not displayed correctly while overriding justify-classes in custom RTE configuration added

#11 Updated by Alexander Opitz over 1 year ago

So does this issue still exists or can the issue be closed?

#12 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue; moreover the related issue has been closed by request of its author.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF