Bug #81815

TYPO3 307-redirects to URL with duplicate 'type' GET param

Added by Thomas Mayer over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-07-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This issue was initially reported by a user against realurl and metaseo via
https://github.com/dmitryd/typo3-realurl/issues/499
https://github.com/webdevops/TYPO3-metaseo/issues/497

with versions:

MetaSEO version: 3.0.0
TYPO3 version: 8.7.2
PHP version: 7.1.6
RealUrl version: 2.2.1

How to reproduce:

Have a realurl config like this

...
'fileName' => array (      
    'index' => array (
        ...
        'sitemap.xml' => array (
            'keyValues' => array (
                'type' => 841132,
            ),
        ),

Then realurl somehow passes that over to TYPO3. Dmitry Dulepov describes it as follows:

" RealURL does not call the core. It is the other way: TYPO3 core calls RealURL here. Inside this call RealURL parses the URL and sets $_GET['id'] and other query string parameters.

The function you found is most likely responsible. It sets the type argument explicitly but it also uses addQueryString without excluding type. So type argument will appear twice in the URL."

TYPO3 then initiates a request with duplicate type parameter:

~ $ curl -I http://www.jh-moehringen.de/robots.txt
HTTP/1.1 307 Temporary Redirect
Date: Thu, 06 Jul 2017 14:12:43 GMT
Server: Apache
Location: http://www.jh-moehringen.de/index.php?id=3&type=841133&type=841133
Vary: Accept-Encoding
Content-Type: text/html; charset=UTF-8

There is to note that this redirect can't come from realurl or metaseo because both won't 307-redirect anywhere. But TYPO3 core does, like in TSFE https://github.com/TYPO3/TYPO3.CMS/blob/f8f0acbdd83631226bf7143e54318f9382d69267/typo3/sysext/frontend/Classes/Controller/TypoScriptFrontendController.php#L2865

#1

Updated by Thomas Mayer over 4 years ago

  • Subject changed from TYPO3 307-redirects to URL with duplicate GET params to TYPO3 307-redirects to URL with duplicate 'type' GET param
#2

Updated by Thomas Jirasko over 4 years ago

The update to TYPO3 8.7.3 did not solve the problem.

#3

Updated by Georg Ringer almost 3 years ago

  • Status changed from New to Needs Feedback

can you retest this with version 9 as routing changed completly. probably solved there.

#4

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF