Bug #81898

Extbase: List IRRE-children does not work, if using the property attribute of f:form.textfield

Added by Gernot Ploiner over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-07-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you want to list all children of an IRRE-element, it does not work if they are form-fields with property="xxx".

To reproduce follow these steps:
  • intall the attached extension in TYPO3 8.7
  • create a page with a TS-Template and add the extension's template
  • add this to your setup to get an output: page.20 < styles.content.get
  • set the storage pid of the extension (e.g. with the constant editor)
  • go to the BE-Module list and create a record of type father and add some children (at least 2)
  • add the plugin of the extension to see the output in the frontend

Now you can see the problem: Only the first child is listed. If you remove the property attribute in the file Resources/Private/Partials/Father/FormFields.html in line 19 all children are visible.

This problem was not in TYPO3 6.2 and 7.6.
Be careful: The attachement is not the same extension as in Ticket #81897 !!!


Files

wp_test_1.0.0_201707171354.zip (522 KB) wp_test_1.0.0_201707171354.zip Gernot Ploiner, 2017-07-17 15:55

Related issues

Is duplicate of TYPO3 Core - Bug #81597: property attribute of form input field viewhelper breaks f:for each loopClosedDaniel Goerz2017-06-16

Actions
#1

Updated by Daniel Goerz over 3 years ago

  • Is duplicate of Bug #81597: property attribute of form input field viewhelper breaks f:for each loop added
#2

Updated by Daniel Goerz over 3 years ago

  • Status changed from New to Closed

Hi Gernot,

thanks for reporting this issue. This looks like a duplicate of #81597 which was recently solved. Please apply the patch of #81597 and check if your issue goes away.

If your error still exists with the applied patch, please reopen this ticket or create a new one.

Closed as resolved and duplicate.

Also available in: Atom PDF