Bug #81897

Extbase: delete last IRRE-children does not work

Added by Gernot Ploiner over 3 years ago. Updated almost 3 years ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2017-07-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This Bug exists at least since TYPO3 6.2.

If you want to delete the children of an element, it works, but not with the last one.

To reproduce follow these steps:
  • intall the attached extension in TYPO3 8.7
  • create a page with a TS-Template and add the extension's template
  • add this to your setup to get an output: page.20 < styles.content.get
  • set the storage pid of the extension (e.g. with the constant editor)
  • go to the BE-Module list and create a record of type father and add some children (at least 2)
  • add the plugin of the extension to see the output in the frontend
  • edit your father-record in the frontend. You should see the father-title and the children-titles.
  • delete all children except one child and save -> it works.
  • edit again, delete the last child and save -> it does not work, the child does not get deleted.

Files

wp_test_1.0.0_201707171329.zip (521 KB) wp_test_1.0.0_201707171329.zip Gernot Ploiner, 2017-07-17 15:41
#1

Updated by Gernot Ploiner over 3 years ago

  • Subject changed from Extabse: delete last IRRE-children does not work to Extbase: delete last IRRE-children does not work
#2

Updated by Susanne Moog almost 3 years ago

  • Category set to Extbase

Also available in: Atom PDF