Bug #82018

Once a linkwizard created an external link it will stay external

Added by Jigal van Hemert over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2017-08-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you use the link wizard in an RTE to modify an External URL to a Page link the attribute data-htmlarea-external="1" will stay causing the link to remain an external URL. The next time you edit the link the External URL tab opens with a not so pretty URL as link uri.

The cause is that in UrlLinkHandler.js the data-htmlarea-external="1" is set, but in none of the other link handler scripts it is removed or set to "0".

#1

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Closed

Not reproducible on 8.7.7.

The attribute data-htmlarea-external="1" is no more present on the links handled by CKEditor
(take also a look at typo3/sysext/recordlist/Resources/Public/JavaScript/UrlLinkHandler.js) and the behavior remains correct.

when you change the link from external to page, the next time you edit it, the correct page tab opens.

We are sorry, but we close this issue as now TYPO3 uses CKEditor and RTEHtmlarea development has been stopped.

RTEHtmlarea has been decoupled from the core and its code is available on GitHub:
https://github.com/FriendsOfTYPO3/rtehtmlarea

If you still need this fixed please create a PR on GitHub

If you think that this is the wrong decision, please reopen it or open a new issue with a reference to this one. Thank you.

#2

Updated by Jigal van Hemert over 3 years ago

  • Status changed from Closed to New

Reopened because the TYPO3 version was specified as 7. In v8 the line is removed in UrlLinkHandler.js but in v7 it is still present.

In v7 it's necessary for \TYPO3\CMS\Core\Html\RteHtmlParser::TS_links_db() to keep external URL's unchanged. In v8 the handling is refactored and the attribute is no longer needed so it was removed completely.

#3

Updated by Susanne Moog over 2 years ago

  • Sprint Focus set to On Location Sprint
#4

Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from New to Closed
  • Sprint Focus deleted (On Location Sprint)

Now version 7 has reached the end of its support period, and therefore I am closing this one.

Of course, if you think that this decision is wrong, reopen it or ping me.

Also available in: Atom PDF