Bug #82087

Finisher identifier unused for translations

Added by Mathias Brodala 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2017-08-11
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The specific finisher identifier used in a form definition is currently only used to look up a finisher within finishersDefinition. Internally another identifier is built based on the finisher class name which is then used e.g. to perform finisher option translations.

It would be very useful if the finisher identifier from the form definition was used or at least considered here. This would e.g. allow for using a common translation file for the EmailToSender and the EmailToReceiver finisher to have separate subject translations. Currently one is forced to set a separate translation file for each of these since the translation key is always the same. Thus with two finishers in a form you already need two separate translation files for this, the more forms you have the more translation files you need.


Related issues

Duplicates TYPO3 Core - Bug #81591: Translation of email finisher subject Resolved 2017-06-16

History

#1 Updated by Mathias Brodala 3 months ago

  • Duplicates Bug #81591: Translation of email finisher subject added

#2 Updated by Mathias Brodala 3 months ago

  • Status changed from New to Closed

This was fixed with #81591

Also available in: Atom PDF