Bug #81591

Translation of email finisher subject

Added by Wolfgang Freund 6 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Should have
Category:
Form Framework
Target version:
-
Start date:
2017-06-16
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi there,

as stated in the documentation here:
https://docs.typo3.org/typo3cms/drafts/code.tritum.de/TYPO3.CMS/Form_Documentation/Concepts/Index.html#concepts-frontendrendering-translation-finishers

the subject of the email finishers should translatable via:

<!-- Form Finishers -->
            <trans-unit id="finisher.EmailToReceiver.subject">
                <source>My own receiver subject</source>
            </trans-unit>
            <trans-unit id="finisher.EmailToSender.subject">
                <source>My own sender subject</source>
            </trans-unit>

But is still uses the default subject used in the YAML-File:

finishers:
  -
    identifier: EmailToReceiver
    options:
      subject: 'Message from website'
      recipientAddress: test@test.com
      recipientName: 'Testname'
      senderAddress: noreply@test.com
      senderName: '{firstname} {lastname}'
      replyToAddress: '{email}'
      carbonCopyAddress: ''
      blindCarbonCopyAddress: ''
      format: html
      attachUploads: 'false'
      translation:
        language: 'en'
  -
    identifier: EmailToSender
    options:
      subject: 'Thank you for your mail'
      recipientAddress: '{email}'
      recipientName: ''
      senderAddress: noreply@test.com
      senderName: 'Testname'
      replyToAddress: ''
      carbonCopyAddress: ''
      blindCarbonCopyAddress: ''
      format: html
      attachUploads: 'false'

Related issues

Duplicated by TYPO3 Core - Bug #82087: Finisher identifier unused for translations Closed 2017-08-11

Associated revisions

Revision 615d2dae (diff)
Added by Ralf Zimmermann 3 months ago

[BUGFIX] EXT:form - use configured finisher identifiers for translations

Use the configured finisher identifier for translation keys instead of
the finisher class name.

Resolves: #81591
Releases: master, 8.7
Change-Id: Ib78e942121b4b6e299ae394c30261603760444f7
Reviewed-on: https://review.typo3.org/53363
Tested-by: TYPO3com <>
Reviewed-by: Denis Mir <>
Tested-by: Denis Mir <>
Reviewed-by: Bjoern Jacob <>
Tested-by: Bjoern Jacob <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision ce48791a (diff)
Added by Ralf Zimmermann 3 months ago

[BUGFIX] EXT:form - use configured finisher identifiers for translations

Use the configured finisher identifier for translation keys instead of
the finisher class name.

Resolves: #81591
Releases: master, 8.7
Change-Id: Ib78e942121b4b6e299ae394c30261603760444f7
Reviewed-on: https://review.typo3.org/53843
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53363

#2 Updated by Ralf Zimmermann 6 months ago

  • Assignee set to Ralf Zimmermann

You are right. There is a bug. For now, the translation key is calculated from the finisher implementation class name (like EmailFinisher) without the "Finisher" suffix.
This is why a translation keys like "finisher.EmailToReceiver.subject" won't work because EXT:form searches for "finisher.Email.subject" (the implementation class name ist called EmailFinisher.php).

#3 Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53363

#4 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53843

#5 Updated by Ralf Zimmermann 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Mathias Brodala 3 months ago

  • Duplicated by Bug #82087: Finisher identifier unused for translations added

Also available in: Atom PDF